spamd: could not create INET socket on 127.0.0.1:783

0

Spamassassin ist für die Spamverwaltung bei Mails zuständig – grob formuliert. Als ich letztens Änderungen an der Config vorgenommen hatte, wollte ich dieses Programm mittels /etc/init.d/spamassassin restart neustarten, doch ich erhielt folgende Fehlermeldungen:

Jul 15 18:31:34.086 [25988] warn: server socket setup failed, retry 2: spamd: could not create INET socket on 127.0.0.1:783: Die Adresse wird bereits verwendet

Im Internet habe ich länger gesucht und es gibt viele Beiträge, dass es ein Bug von famd bzw. spamd ist, da diese Programme sich willkürlich die Ports aussuchen, aber nirgends stand eine klare Lösung für das Problems. Durch Zufall bin ich dann auf eine Lösung gestoßen.

Ich verwende Debian 6 und mit dem Befehl top ruft man die Prozessanzeige auf. Dort war dann der Prozess spamd noch aktiv, was wohl den Fehler beim Neustart vom Spamassassin verursacht hat, denn scheinbar lief es noch. Daher einfach schrittweise folgendes in der Konsole ausführen:

[AdSense-A]

  1. /etc/init.d/spamassassin stop eingeben
  2. top eingeben => Prozesse aufrufen
  3. die PID Nummer vom spamd Prozess merken (4-stellig)
  4. k eingeben => Kill-Befehl für Prozesse
  5. jetzt die 4-stellige PID Nummer eingeben
  6. Enter drücken
  7. /etc/init.d/spamassassin start eingeben
  8. Fertig

Nachtrag

Die Ursache des Problems ist trotzdem geblieben, da der Pfad für die PID-Datei bei Spamd nicht festgelegt ist und damit die PID-Datei nicht angelegt werden. Die PID-Datei ist meines Wissens für das Startverhalten eines Programms unter Linux verantwortlich.

Ich habe das Problem damit gelöst, dass ich einen Ordner angelegt habe (außerhalb des Bereichs, der durch eine Domain erreicht werden kann, z.B. /home/spamd/) und diesen Ordner dem Benutzer spamd sowie der Gruppe spamd zugewiesen habe – je nach dem, wie spamd eben verwaltet wird.

Nun öffnet man die Datei /etc/default/spamassassin mit dem Befehl nano.  Dort gibt es den Eintrag SAHOME=“….“

Zwischen die Anführungszeichen habe ich den Pfad zu dem gerade angelegten Ordner gesetzt, z.B. SAHOME=“/home/spamd/“. Diese Datei speichern und spamd neu laden und neu starten.

Problem verschwunden.

Leave A Reply

Your email address will not be published.